路由器 OSPF 虚连接的配置

实训三十六 路由器 OSPF 虚连接的配置

一、实验目的

1. 掌握多区域 OSPF 虚连接的配置

2. 理解 OSPF 虚连接的意义

二、应用环境

在大规模网络中,我们通常划分区域减少资源消耗,并将拓扑的变化本地化。由于实际

环境的限制,不能物理的将其他区域环绕骨干区域,可以采用虚连接的方式逻辑的连接到骨

干区域。

三、实验设备

1. DCR-2655 三台

2. 网线(交叉线) 三条

 

六、

实验步骤

第一步:参照上表配置各接口地址,并测试连通性

Router_config#hostname RA

RA_config#interface g0/3

RA_config_g0/3#ip address 192.168.1.1 255.255.255.0

RA_config_g0/3#no shutdown

RA_config_g0/3#exit

RA_config#interface g0/4

RA_config_g0/4#ip address 192.168.0.1 255.255.255.0

RA_config_g0/4#no shutdown

RA_config_g0/4#exit

RB 、RC 配置 略

第二步:路由器 A 的配置

RA#config

1

RA_config#router ospf 9

RA_config_ospf_9#network 192.168.0.0 255.255.255.0 area 3

RA_config_ospf_9#network 192.168.1.0 255.255.255.0 area 1

RA_config_ospf_9#exit

第三步:路由器 B 的配置

RB_config#router ospf 9

RB_config_ospf_9#network 192.168.2.0 255.255.255.0 area 0

RB_config_ospf_9#network 192.168.1.0 255.255.255.0 area 1

RB_config_ospf_9#exit

第四步:路由器 C 的配置

RC_config#router ospf 9

RC_config_ospf_9#network 192.168.2.0 255.255.255.0 area 0

RC_config_ospf_9#network 192.168.3.0 255.255.255.0 area 0

RC_config_ospf_9#exit

第五步:查看路由器 A 的邻居表

RA_config#show ip ospf neighbor

----------------------------------------------------------------------------

OSPF process: 9

AREA: 1

Neighbor ID Pri State DeadTime Neighbor Addr Interface

192.168.2.1 1 FULL/DR 36 192.168.1.2 GigaEthernet0/3

AREA: 3

Neighbor ID Pri State DeadTime Neighbor Addr Interface

----------------------------------------------------------------------------

我们看到路由器 B ROUTER-ID 192.168.2.1

第六步:查看路由器 B 的邻居表

RB_config#show ip ospf neighbor

----------------------------------------------------------------------------

OSPF process: 9

AREA: 0

Neighbor ID Pri State DeadTime Neighbor Addr Interface

192.168.3.1 1 FULL/BDR 34 192.168.2.2 GigaEthernet0/4

AREA: 1

Neighbor ID Pri State DeadTime Neighbor Addr Interface

192.168.1.1 1 FULL/BDR 37 192.168.1.1 GigaEthernet0/3

---------------------------------------------------------------------------- 我们看到 A ROUTER-ID 192.168.1.1

第七步:配置虚连接

RA_config#router ospf 9

RA_config_ospf_9#area 1 virtual-link 192.168.2.1 !注意是 ROUTER-ID

RB_config#router ospf 9

RB_config_ospf_9#area 1 virtual-link 192.168.1.1 !注意是 ROUTER-ID

第八步:查看虚连接

RA_config#show ip ospf virtual-link

Virtual Link Neighbor ID 192.168.2.1 (UP)

Run as Demand-Circuit

TransArea: 1, Cost is 1

Hello interval is 10, Dead timer is 40 Retransmit is 5

INTF Adjacency state is IPOINT_TO_POINT

RB_config#show ip ospf virtual-link

Virtual Link Neighbor ID 192.168.1.1 (UP)

Run as Demand-Circuit

TransArea: 1, Cost is 1

Hello interval is 10, Dead timer is 40 Retransmit is 5

INTF Adjacency state is IPOINT_TO_POINT

七.OSPF 路由配置状态

使用说明

为了建立一条 virtual link ,必须在这个 virtual link 的两端都进行配置, 如果只在一端配置,

这个 virtual link 将无法工作。 参数 area-id 必须是一个非 0 , 因为 virtual link 的 transit area 必

须是一个非 backbone 区域。 当然 virtual link 两端所配置的 area-id 必须相同。在配置时,neighbor-ID

必须是对端路由器的 ospf router-id , 否则将无法建立 virtual link,即使所配置的 neighbor-ID 是对

端的某一个 IP 地址。 必须保证 virtual link 两端的所有的参数都必须一致。 virtual-link 上所配置的

认证参数只有在 backbone 区域配置了相应的认证方法才生效(通过命令 area authentication )。 在

virtual -link 上最多只能配置一中认证参数, 也就说 MD5 和明文认证是互斥的。在 virtual link 连接

建立完成后,也就是与邻居的邻接状态到达 FULL 后, virtual link 将工作在 Demand Circuit 模式, 也

就是说不在发送周期性的 Hello 报文和 LSA 刷新报文。 使用命令 no area area-id virtual-link

neighbor-ID 可以取消先前配置的 virtual link。

使用命令 show ip ospf virtual-link 可以查看 virtual

link 的状态。

热门文章

暂无图片
编程学习 ·

exe4j详细使用教程(附下载安装链接)

一、exe4j介绍 ​ exe4j是一个帮助你集成Java应用程序到Windows操作环境的java可执行文件生成工具,无论这些应用是用于服务器,还是图形用户界面(GUI)或命令行的应用程序。如果你想在任务管理器中及Windows XP分组的用户友好任务栏…
暂无图片
编程学习 ·

AUTOSAR从入门到精通100讲(126)-浅谈车载充电系统通信方案

01 引言 本文深入研究车载充电系统策略,设计出一套基于电动汽车电池管理系统与车载充电机的CAN通信协议,可供电动汽车设计人员参考借鉴。 02 电动汽车充电系统通讯网络 电动汽车整车控制系统中采用的是CAN总线通信方式,由一个整车内部高速CAN网络、内部低速CAN网络和一个充电…
暂无图片
编程学习 ·

CMake(九):生成器表达式

当运行CMake时,开发人员倾向于认为它是一个简单的步骤,需要读取项目的CMakeLists.txt文件,并生成相关的特定于生成器的项目文件集(例如Visual Studio解决方案和项目文件,Xcode项目,Unix Makefiles或Ninja输入文件)。然…
暂无图片
编程学习 ·

47.第十章 网络协议和管理配置 -- 网络配置(八)

4.3.3 route 命令 路由表管理命令 路由表主要构成: Destination: 目标网络ID,表示可以到达的目标网络ID,0.0.0.0/0 表示所有未知网络,又称为默认路由,优先级最低Genmask:目标网络对应的netmaskIface: 到达对应网络,应该从当前主机哪个网卡发送出来Gateway: 到达非直连的网络,…
暂无图片
编程学习 ·

元宇宙技术基础

请看图: 1、通过AR、VR等交互技术提升游戏的沉浸感 回顾游戏的发展历程,沉浸感的提升一直是技术突破的主要方向。从《愤怒的小鸟》到CSGO,游戏建模方式从2D到3D的提升使游戏中的物体呈现立体感。玩家在游戏中可以只有切换视角,进而提升沉浸…
暂无图片
编程学习 ·

flink的伪分布式搭建

一 flink的伪分布式搭建 1.1 执行架构图 1.Flink程序需要提交给 Job Client2.Job Client将作业提交给 Job Manager3.Job Manager负责协调资源分配和作业执行。 资源分配完成后,任务将提交给相应的 Task Manage。4.Task Manager启动一个线程以开始执行。Task Manage…
暂无图片
编程学习 ·

十进制正整数与二进制字符串的转换(C++)

Function one: //十进制数字转成二进制字符串 string Binary(int x) {string s "";while(x){if(x % 2 0) s 0 s;else s 1 s;x / 2;}return s; } Function two: //二进制字符串变为十进制数字 int Decimal(string s) {int num 0, …
暂无图片
编程学习 ·

[含lw+源码等]微信小程序校园辩论管理平台+后台管理系统[包运行成功]Java毕业设计计算机毕设

项目功能简介: 《微信小程序校园辩论管理平台后台管理系统》该项目含有源码、论文等资料、配套开发软件、软件安装教程、项目发布教程等 本系统包含微信小程序做的辩论管理前台和Java做的后台管理系统: 微信小程序——辩论管理前台涉及技术:WXML 和 WXS…
暂无图片
编程学习 ·

树莓派驱动DHT11温湿度传感器

1,直接使用python库 代码如下 import RPi.GPIO as GPIO import dht11 import time import datetimeGPIO.setwarnings(True) GPIO.setmode(GPIO.BCM)instance dht11.DHT11(pin14)try:while True:result instance.read()if result.is_valid():print(ok)print(&quo…
暂无图片
编程学习 ·

ELK简介

ELK简介 ELK是三个开源软件的缩写,Elasticsearch、Logstash、Kibana。它们都是开源软件。不过现在还新增了一个 Beats,它是一个轻量级的日志收集处理工具(Agent),Beats 占用资源少,适合于在各个服务器上搜集日志后传输给 Logstas…
暂无图片
编程学习 ·

Linux 基础

通常大数据框架都部署在 Linux 服务器上,所以需要具备一定的 Linux 知识。Linux 书籍当中比较著名的是 《鸟哥私房菜》系列,这个系列很全面也很经典。但如果你希望能够快速地入门,这里推荐《Linux 就该这么学》,其网站上有免费的电…
暂无图片
编程学习 ·

Windows2022 无线网卡装不上驱动

想来 Windows2022 和 windows10/11 的驱动应该差不多通用的,但是死活装不上呢? 搜一下,有人提到 “默认安装时‘无线LAN服务’是关闭的,如果需要开启,只需要在“添加角色和功能”中,选择开启“无线LAN服务…
暂无图片
编程学习 ·

【嵌入式面试宝典】版本控制工具Git常用命令总结

目录 创建仓库 查看信息 版本回退 版本检出 远程库 Git 创建仓库 git initgit add <file> 可反复多次使用&#xff0c;添加多个文件git commit -m <message> 查看信息 git status 仓库当前的状态git diff 差异对比git log 历史记录&#xff0c;提交日志--pret…
暂无图片
编程学习 ·

用Postman生成测试报告

newman newman是一款基于nodejs开发的可以运行postman脚本的工具&#xff0c;使用Newman&#xff0c;可以直接从命令运行和测试postman集合。 安装nodejs 下载地址&#xff1a;https://nodejs.org/en/download/ 选择自己系统相对应的版本内容进行下载&#xff0c;然后傻瓜式安…
暂无图片
编程学习 ·

Java面向对象之多态、向上转型和向下转型

文章目录前言一、多态二、引用类型之间的转换Ⅰ.向上转型Ⅱ.向下转型总结前言 今天继续Java面向对象的学习&#xff0c;学习面向对象的第三大特征&#xff1a;多态&#xff0c;了解多态的意义&#xff0c;以及两种引用类型之间的转换&#xff1a;向上转型、向下转型。  希望能…